Microsoft Excel 2007 — Part 2 Exercises
Class Notes

Part 1 — Exercise Summary
1. Open Excel 2007 Part 2 Exercises.xlsx
2. Save As as shown below:
Office Button | SAVE AS | My Excel 2007 Part 2 Exercises.xlsx
3. Review Worksheet Tab: Exercise Summary.

Part 2 — Exercise 1 - Relative Cell Addressing...

Relative Cell Addressing
1. Select Worksheet Tab: Exercise 1.

2. Total Soda Sales - : = F —
. SWEET SHOP Mﬁ// The formula

a. Select C7. . 2007 Annual Sales 2008 AnnualSiss references 1
CT 8 column to the

b. From Home tab, click AutoSum.

S(c:'m;l 1510,253.00] A/S‘cm;/ $11,585.89 left and 2

ola 1$10,253.00¢ ola 585,

c. Select B5 thru B6. RootBeer | $6.528.00] RootBeer _ $7.376.64 cells above.
5

@~ o (e |

d. Press Enter. o S
3. Copy formulain C7 to G7 o~ fo] =sumiFs:es) ,
A B c D E F B H| | The Copied
a. Select C7. . SWEET SHOP formula
b. From Home ta b, CliCk COpy 3 2007 Annual Sales 2008 Annual Sales // references 1
4 Soda Soda column to the
C. SeleCt G7 s | Cola $10,253.00 Cola $11,585.89 / Ieft and 2
1 5 RootBeer $6,528.00 Root Beer $7,376.64
d. From Home ta b' click Paste. 7 |Total $16,781.00  Total @/ |s18.962.53 cells above.
s (i
4. Copyformulain G7to €13 [ A ] Thecopied
a. Select G7. . SWEET SHOP formula references
. : 2007 Annual Sales 2008 Annual Sale 1 column to the left
b. From Home tab, click Copy.|. and 2 cells above.
2 |Soda Soda
c. Select C13. s | Cola $10,253.00 Cola 7585.89 The formula does
. 6  Root Beer $6,528.00 $7,376.64 .
d. From Home ta b, click Paste.|: ro $16,781.00 $18,962.53 not include B10.
9 Ice Cream Ice Cream The CopiedformUla
10| Chocolate $5.243.00 Chocolate $5.924.59 .
11| Strawberry $1,258.00 Strawberry  $1.421.54 calculates relative
12| Vanilla $7,182.00 Vanilla $8,115.66 to the cell it is in.
13 | Total @ | i Total

5. Edit formula in C13 to include the missed cell (B10)
a. Select C13
b. In the Formula Bar, change B11to B10.! =~ # « f« | =SUM(B10{B12)
c. Click & Tip: Ctrl Enter are the shortcut keys for this button.

6. Optional:
a. Copy formulain C13 to G13, G19 and C19. Tip: Ctrl Cin C13 and Ctrl Vin G13, G19, C19.
b. AutoSum in C21 of cells C19 thru C7.
c. AutoSum in G21 of cells G19 thru G7.
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7. Copy formulain L4 to L5 through L10 using Fill Handle

a.

8. Copy formulain L8 toJ1

Notice each formula references the 2 cells immediately to the left.

a.

b.

Copy formula in L8 to J1.

Notice the formula in J1 references the
2 cells immediately to the left (H1 + 11).
Click Undo.

fe | =H1+11
H| I ] K

9. Move the formulain L8 to J1

a.

b.

d

10.0ptional:
a.

Select L8
Hold the mouse over the black edge of cell.
The cursor will change to a Move cursor. +»

Click and drag the cell to J1. FETD)
Notice the formula still references the original cells. — ¢ W 1] K
Click Undo. 106

Copy formula in L8 to J1 using shortcut keys: Ctrl C to copy; Ctrl V to paste.

SAVE |l

Inserting Cells
1. Insert cellinJ7

Select J7. = H

a.
. . Insert Delete Format
b. From Home tab, Cells group, click the icon above the word Insert. -~ -
c. Notice a cell is inserted and remaining cells moved down.
d. Click Undo.
e. From the Home tab, Cells group, click the word “Insert.”
f. Select Insert Cells.
g. Select Shift cells right.
h. Click OK.
. . () Entire column
i. Click Undo.
2. Insert cellsinJ7 thru L7
a. Select cells J7 thru L7. 2| w105 3 B
b. From Home tab, Cells group, click the icon above Insert. izl — C___Jiserted cels
c. Click Undo. 2 8 1o s o s
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Wrapping Text Within Cell
1. Wrap text in A2 (2008 Annual Sales)

a.
b.

Select cell A2.

Place I-beam cursor in formula bar, between 2007 and Annual and click.
® " fe | 2008 Annual Sales

While holding down the Alt key, tap the Enter key; Release the Alt key.

Note: It will look like the 2008 disappeared, but it didn’t!
Optional: Click the “Expand Formula Bar” button. | A2~ (. % « f||jnnualsales ﬁ)
Click again to “Collapse Formula Bar.” & C c i
Press Enter.

Resize row 2 to accommodate the 2 lines of text in cell A2.

How? . SWEET SHOP
1) Hold cursor over line between row number 2 and 3. 2008
2) The cursor will change to % - Annual Sales 2009 Ann

3) Hold left mouse button down and drag down until row is wide enough.

2. Wrap text as label is being typed into the cell

a. Select cell J13 using the Name Box. Dg/ h:"’ 1: —
1) Click in the Name Box ™ I coors - .
2) Type j13 \ e
3) Press Enter R
b. Type the letter “a” A g
c. While holding down the Alt key, tap the Enter key; Release the Alt key.
d. Type the letter “b”
e. Press Enter.
f. Click Undo.
SAVE L]

Hide/Unhide Columns
1. Hide columns Jthru L

a.
b.
C.
d.

Select cells J5 through L5.

From the Home tab, Cells group, click Format (icon or word).
Select Hide & Unhide.

Select Hide Columns.

Notice the column letters skip from | to M (J thru L are hidden).
2. Unhide columns J thru L

a.
b. From the Home tab, Cells group, click Format (icon or word).
C.
d

Select cells 11 thru M1.

Select Hide & Unhide.

. Select Unhide Columns.
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Part 3 — Exercise 2: Absolute Cell Addressing...
Absolute Cell Addressing (1°" Example)
1. Select Worksheet Tab: Exercise 2.

2. Create & copy a formula for calculating the % of students liking each flavor

a. Select C4. A b 2
ICE CREAM SURVEY

1
b. Type = 2 Formula: Students / Total
C- C“Ck B4. £ AVOR i 0% O DT A
4 |Chocolate 18|=B4/B12
d' Type / s |Strawberry 12
e. Click B12. 5
f. Click
g. From Home tab, Number group, click %
h. From C4, click & drag Fill Handle to C12. (produces relative cell reference formulas)
% of TOTAL
0.225 |:B4fB12

#DIV/0! Results [-ssmis #DIV/0! Means cannot divide by zero. B13 is empty.

#DIV/0! — —B6/B14

#DIV/0! =B7/B15

#DIV/0! FormUIa =B8/B16

#DIV/0! View . |[=BoB17

#VALUE! (Ctrl ~) " |=Blo/B18 H#VALUE! Sometimes means the formula is referring to text. (B18)

#VALUE! =B11/B19

0% |-B12/B20 IB20 contains the sales figure 25,888

i. Select C4.

j. Inthe Formula Bar, place the I-beam cursor anywhere within B12. This cell must
“absolutely” never change. =84/B19 or =84/B1l or =84/8f2  or =B45512

k. Press F4.

l. Click &

m. From C4, click & drag Fill Handle to C12. (produces absolute cell reference formulas)
Look at the Status Bar!!!

Absolute Cell Addressing (2" Example)

1. Create & copy a formula for calculating the amount of sales commission
Scroll down so that only the Annual Sales & Commission can be seen.
Select C20.

Type =

Click B20.

Press *

Click C18.

Press F4. (will change C18 to SC$18)

Click «

From C20, click & drag Fill Handle to C23. (produces absolute cell reference formulas)
Look at the Status Bar!!!

Q

TSm0 T

SAVE
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Part 4 — Exercise 3: Fill Handle...
Fill Handle

1. Fill Handle on single cell (Repeat these steps for each column from A thru F
a. FromAl,clickanddrag @ ‘2 & ¢ o F !
. 1 |Jan August Mon Wednesday 1| Thursday, January 15, 2009
the fl” handle dOWI’\ 2 |Feb SeptemTue Thursday 1 Friday, January 16, 2009
. 3 |Mar OctobeiWed Friday 1| Saturday, January 17, 2009
ClppI’OXImatE/y 10 FOWS. = Apr Noveml|Thu Saturday 1| Sunday, January 18, 2009
5 |MayDecemEFri  Sunday 1| Meonday, January 19, 2009
6 (Jun January Sat Monday 1| Tuesday, January 20, 2009 Ce” F7 ShOWS Hit because the
7 |Jul FebruarSun Tuesday 1| SRR . .
8 |AugMarch Mon Wednesday 1| Thursday, January 22, 2009 COIUmn is not Wlde enOUgh-
9 |Sep April  Tue Thursday 1 Friday, January 23, 2009
10 |Oct May  Wed Friday 1| Saturday, January 24, 2009
2. Change the column width of multiple columns at one time
a. Hold the mouse over the center of the A in column A. The cursor will change tod.
b. Click and drag the cursor to include column F, then release the mouse button.
c. Hold the cursor over the line between any 2 previously selected column letters.
When the cursor changes to<+*, double click.
3. Prevent Fill Handle from sequencing
a. Select Al.
b. Hold down the Ctrl key while dragging the Fill Handle.
4. Create a series of numbers I
G H|I
a. Select G1.
b. While holding down the left mouse button, drag the mouseto G2. | | 1 °
c. Release the mouse button. 221
d. Click and drag the fill handle down approximately 10 cells.
e. Repeat steps a. through d. for the numbers in column H and then column I.
5. Using the Fill handle, K L [ M| N 0
-
complete the CD 1 CD Collectl.on
CoIIection Spreadsheet 2 ALBUM ARTIST| DISC |TRACK SONG
* 3 The White Album |Beatles| Disc ] Track 1 [Back In The U.S.S.R.
4 The White Album |Beatles |Pi==1 |Track 2 |Dear Prudence
5 The White Album |Beatles || g L|Track 3 |Glass Onion
6 The White Album |Beatles || ? | |Track 4 |Ob-La-Di, Ob-La-Da
7 |The white Album |Beatles || :CI:U L [Track 5 |Wild Honey Pie
8 The White Album |Beatles || — L |Track 6 |[The Continuing Story Of Bungalow Bill
9 |The White Album |Beatles || E L [Track 7 |While My Guitar Gently Weeps
10 | The white Album |Beatles || 8 | [Track 8 |Happiness Is A Warm Gun
11 | The White Album |Beatles |rsel [Track 9 (Martha My Dear
12 |The White Album |Beatles |Disc 1 Track 10I'm So Tired
13 | The White Album |Beatles |Disk 2}Track 1 |Birthday
14 | The White Album |Beatles |Disk 2 [Track 2 [Yer Blues
15 The White Album |Beatles |I ? [Track 3 |Mother Nature's Son
@ Everybody's Got Something To Hide
16 | The White Album |Beatles |[ 'g ? [Track 4 |Except Me And My Monkey
17 | The White Album |Beatles |[ :r:u 2 Track 5 |Sexy Sadie
18 The White Album |Beatles |[ — 2 |Track 6 |Helter Skelter
19 The White Album |Beatles |[ E ? (Track 7 |Long, Long, Long
20 The White Album |Beatles |[ 55 2 [Track 8 |[Revolution 1
21 | The White Album |Beatles [n%r’(z Track 9 |Honey Pie
SAVE
22 |The White Album |Beatles |Disk 2 [Track 10Savoy Truffle
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Date Formats
1. Change Date format in column F

a.

i.
J-

Sm o a0 T

Select any date in column F.

From Home tab, Number group, click arrow next to Date. ™ O
Select Short Date. S
Select Long Date.

Select More Number... Formats.

Scroll through the various Date formats. Notice there is no “March 2001” format.
Select Custom.

Delete whatever is in the Type box
Note: The Sample box displays the number of days since [ .-
January 1, 1900 to the date you selected for this exercise. >
Note: As you type each of the following letters into the Type box, look at the Sample.
Type mmmm yyyy (note the space between the m’s and y’s).| my a
Click OK. s

Mmmm yyyy

Type:

Format Painter
1. Format cell and copy format to another cell using the Format Painter

a. Select B3.
b. From the Home tab, apply new formatting by changing the circled items.
11 vA' = = =||®|  SiwapTed
' | E' %E *E+E 5 Merge & Center ~
c. Make sure B3 is still the active cell. = bt
53 Copy
d. From the Home tab, Clipboard group, click Format Painter. ™" G
e. Select cell D3. This cell now takes on the same formatting. o
f. Click cell C3. Nothing happens.
g. Select cell D3.
h. Double click Format Painter.
i. Click cell C3, A1, F3. All selected cells take on the same formatting.
Notice that the F3 Custom date format changed to General format.
j. To turn off the Format Painter, either press the ESC key or click Format Painter.
Indenting
1. Indent Q2 thru Q8
a. Select Q2 thru Q8.
b. From the Home tab, Alignment group, click the Increase Indent = = =¥ =uere
button 2 times, a Q EE = *: | Merge & Center ~
1 Exercise 3 - Fill Handle 1 |Exercise 3 - Fill Handle Allgnment &
2 [Fill Handle 2 Fill Handle
3 [Column Width 3 Column Width
4 |ctrl Fill Handle — 4| ctiFill Handle
5 |Date Formats & Date Formats
6 VerﬁcalAI_ignment 6 Vertical Alignment
SAVE ; IF:;?:;:;'{:;?;"ST} ; r:r;:na;:gal(:;fsrlist)
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Part 5 -

Exercise 4: Sorting...

Sorting
1. Sort List (a.k.a. database) by single column

a.
b.
C.

Select any name in the First Name column. 5 oo 7N -
From the Home tab, Editing group, click Sort & Filter. fl‘;_ @j‘%
Select Sort Newest to Oldest.
Notice the List sorts by First Name.

Select any date in the Birth Date column.

. Click Sort & Filter.

Select Sort Oldest to Newest.
Notice that 2/11/1819 is before September 29, 1994. This is because Excel does not
recognize any dates prior to January 1, 1900.

2. Sort List by multiple columns

S®m 0 o0 T

Select any cell in the data area of the spreadsheet.
Click Sort & Filter.

Column Sort On Crder

Se I ect C u Sto m So rt . Sortby || astName Values v| Atz
LastName ... Aoz

Sort by Last Name, A to Z. e s s,

Cl i Ck Ad d Level . I “’gl&dd Level H )( Delete Level “ 23 Copy Level H I Options... J My data has headers

Column Sort On Order

Sort by First Name. i 1
Click OK. = @

Values w| |AtozZ

Values ¥ Atz

nsert column and sort

0T o

o

\_..—..jqq._h

Select any cell in column E.

From the Home tab, Cells group, click the word “Insert.”

Select Insert Sheet Columns.

Notice that Don Adams was born in New York.

Sort the First Name column. (select any cell in column B, click Sort & Filter, A to Z)
Find Don Adams; notice the Town is no longer New York.

This is because the inserted column contains no data. It separates the database into
separate 2 databases.

Click Undo.

Select E4.

Type Phone.

Press Enter.

Sort the First Name column.

This example also holds true for inserted rows.
4. Freeze rows 1-4 and columns A-B from scrolling off screen

a.
b.
C.

SAVE

Select C5 él = =] Split
From the View tab, Window group, click Freeze Panes, Freeze Panes. = #eq fee)

Window

Experiment with the scroll bar. Notice the areas that always remain on the screen.
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Part 6 — Exercise 5: Linking Formulas...

Rename Worksheet Tab
1. Rename worksheet tab Exercise 5 to 2009
a. Double click the worksheet tab Exercise 5.
b. Type 2009.
c. Press Enter.
Borders
1. Add Borders to the spreadsheet
a. Select (highlight) cells A3 thru G7.
b. From the Home tab, Font group, click caiibr ) PP
the arrow on the Borders button. B/ 7 U-[sQl-A-
c. Select All Borders. HH Al Borders
Conditional Formatting
1. Add Conditional Formatting to the spreadsheet
a. Select C4 thru G7.

b. From the Home tab, Styles group, click Conditional Formattlng
c. Select Data Bars. + - -laxl[==alp| [Gwme e (BN = ﬁm = E]) Seem or d
ru-@&-A- £ || SHuersencener = [8 - % o |58 S\ Conotonat froma nsert Deete Fomat | Sena fin

d. Selectanycolor. - 5 e

‘ 2009 Sa[;es Reporl:E ’ ’ " : :
Qtrl Qtr2 Qtr3 Qtr 4 Total Exercis - - E - H-
SAVE rarsl oorr B s oo A peie] e iy
1,515 5,951 7,971 3,733 [ 19,170 Conditi |=] lonsets — ’muimfie cel
14,447 | 19,503 | 16,887 | 18,467 | 69,304 Copy V1) i e }m s
Copy Worksheet
1. Make copy of the 2009 worksheet, rename, and edit
a. Right click the “2009” worksheet tab. The goal of this section is to
b. Left click Move or Copy create a worksheet for 2010.
) _- Then, create another
c. Select (move to end) move to enc worksheet that includes only
d. Select Create a copy. the annual (as opposed to
Click OK. [v]iCreate a copy quarterly) sales for each

e. IC year...a summary worksheet.

f. Rename the “2009 (2)” worksheet tab to 2010.

g. Edit report heading to 2010 Sales Report.

1) Select A1.
2) In the Formula Bar, click in front of the 2. # «  Jx | P009 Sales Report

3) Press the Delete key 4 times to delete 2009.
4) Type 2010
5) Press Enter.
h. Delete all data from D4 thru F6 (data in Qtr 2 thru Qtr 4).
Tip: Select D4 thru F6, press the Delete key.

SAVE
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2. Make a sales summary worksheet

a.

N ]

= o

SAVE

Right click the “2010” worksheet tab.

b. Left click Move or Copy.
C.
d. Click OK. Note: Because “(move to end)” was not selected, the worksheet was placed

....................................

in front of the Exercise Summary tab.
Using the mouse, point to the “2010 (2)” tab.
Hold the left mouse button down and drag the tab past the “2010” tab.

23
Mo e H| 2010 (2) m=—fstaps; L = icar: = t = ¥ i P ]

Rename the “2010 (2)” worksheet tab to Sum. (short for Summary)

Edit report heading to Sum Sales Report.

Change column headings from Qtr 1, Qtr 2, Qtr 3, Qtr 4, to 2009, 2010, 2011, 2012.
Tip: Select C3, type 2009, press the Tab key, type 2010, repeat as necessary.

Delete all data from C4 thru C6.

Tip: Select C4 thru F6, press the Delete key.

Linking Formulas
1. Create formulas linking annual totals between worksheets

a.

SAVE

oo o

_.T\._.'—-D—qa._h

From the Sum worksheet, select C4.

Type =

SZFect the 2009 worksheet. As.you perforrT\ each step, note the formula
being created in the Formula Bar.

Select G4.

Press «

Note: When pressing the Enter key upon completing a formula, Excel moves the
cursor down causing the cell below the formula to be the active cell. This is true when
creating linking formulas as well. Because the next step requires using the fill handle
to copy the formula, pressing the  button prevents having to press the up arrow
key on the keyboard to select the cell containing the formula to be copied.

Using the fill handle, copy the formula in C4 down to C6.

From the Sum worksheet, select D4.

Type =
As you perform each step, note the formula
Select the 2010 worksheet. youp . P
being created in the Formula Bar.
Select G4.
Press «
H M A B C D E F G
Using the fill handle, copy the formula Sum Sales Report
1 2
n D4 down to D6' 3 Name Emp # 2009 2010 2011 2012 Total
Note~ Theformula In C4 cannot be 4 Mel Gibson 11 25,888 5,357 31,245
. : 5 SanraBullock| 24 24,246 7,575 31,821
copied across to D4 because Excel does ¢ bonaldbuck | 28 | 19,170 1,515 20,685
7 Totals 69,304 | 14,447 = = 83,751

not know to change the tab names in
the formula from 2009 to 2010.
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Insert/Move/Delete Worksheets
1. Insert 2 Worksheets
a. Click the Insert Worksheet tab. ercise 4 | 2009 2010 Sum
b. Repeat Step a.
2. Move Worksheets
a. Experiment with moving the newly created worksheets by clicking and dragging the
worksheet tabs.
3. Delete Worksheets
a. Right click one of the newly created worksheet tabs from Step 1 above.
b. Left click Delete
c. Right click the other newly created worksheet tab from Step 1 above.
d. Left click Delete
Navigate Between Worksheets
1. Ctrl-Page Up, Ctrl-Page Down
a. Select the Example Summary worksheet
Hold down the Ctrl key
Tap the Page Up key to move forward to the next worksheet.
Repeat Steps 2-3 a few times.
Hold down the Ctrl key
Tap the Page Down key to move to the previous worksheets.
g. Repeat Steps 5-6 a few times.
2. Sheet Tab Scroll Buttons
a. Moves to the previous and next worksheets.

"m0 oooT

44+ M| Exercise Summary - Exercise 1 - E

#
b. Moves to the first and last worksheets. o [ e summay
3. Worksheet Tab Scrollbar Shortcut Menu s I i
a. Right click anywhere on the Sheet Tab Scroll area to display a e
Shortcut Menu listing all worksheet tab names. I U
S

4. Adjust size of Horizontal Scroll Bar to display more worksheet tabs
a. Hold the cursor over this are of the Horizontal Scrollbar.
2010 Sum ¥ | M |
b. Click and drag this area to resize the scrollbar, thereby viewing more worksheet tabs.
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Part 7 — Exercise 6: Protecting Worksheets/Sharing Workbooks...

Protect Worksheet

By default, all cells are “locked.” When worksheet protection is turned on, no cells can be
edited. To allow only certain cells to be edited when protection is turned on, the cells to be
edited must be unlocked. This prevents accidental changes to locked cells, and forces the
use to only make changes to unlocked cells.

1. Select worksheet tab Exercise 6.
2. Select cells E7 through F11.
3. Hold down the Ctrl key. This will allow you to select multiple ranges.
4. Select cells E13 through F17
5. Select cells E19 through F23.
6. Release the Ctrl key.
7. From the Home tab, Cells group, click Format
8. In the Protection section, click Locked. protection
By default, this option is active. Clicking ™4 eoteasnect.
it will deactivate this feature, hence, ; ﬁ;ct!”

unlocking the selected cells.
9. Click Format again.
10.In the Protection section, click Protect Sheet...
11.Select/unselect options as desired.
12.Enter a password if necessary. DO NOT FORGET THE PASSWORD!

Share Workbook (File)

This feature allows multiple people to open and make changes to the file at the same time.
Without doing so, if the file is already being used by someone, a Read Only message will
appear upon attempting to open the file. Any changes made while in Read Only mode, can
only be saved if it is saved as a separate file. Now, there will be 2 different versions of the
same file.

1. From the Review tab, Changes group, click Share Workbook.

2. Click the box next to “Allow changes...”

Editing | Advanced

[+]iallow changes by more than one user at the same time. This

ialso allows workbook merging.

3. Click OK
4. Answer Yes when prompted to save.
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Close Workbook (File) and Excel
1. Close the Workbook (file). - -@
a. Click the top X in the upper right corner of the screen., . =

Delete Workbook

Click Start

Click My Documents

Double click the folder, Excel Class

Single click “my Excel 2007 Part 2 Exercises.”
Press the Delete key on the keyboard

Click Yes to delete the file.

ounkwneR
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